Topic: [to 3.63 only] Community mod BAC: Smith, Cooking, Survival, Carpentry, Sewing  (Read 280876 times)


« Reply #525 on: July 12, 2020, 09:32:29 PM »
I just experienced a crash after loading up the game, next to a trap fence I'm building. I had a single split spruce twig in my inventory. I pressed S+M+F, accidentally, then pressed S+R+F to keep building up the traps. Realized I needed more split twigs to continue, and after picking some from the trees nearby, I used  "+"+Y for Tying Equipment, and the game crashed. Weird since it usually crashed before by opening it a second time and not the very first.

Update: Game crashed when I tried to pick up a leather rope
« Last Edit: July 12, 2020, 11:01:08 PM by Zhid_13 »


« Reply #526 on: July 13, 2020, 02:34:18 AM »
After playing more and testing a little with the Tying Equipment, I'm pretty sure that the problem is being caused by leather ropes. First BlankPaper up there saying he had troubles crafting a leather rope, then me having the game crash when I tried to pick up one from a settlement to buy it, and just now, I realized that if I open the Tying Equipment tab, the game doesn't crash instantly. It only crashes if I press the down key to scroll all the way down to the other stuff I need to craft, but the second item in the list is Leather Rope, so as soon as I open it and scroll down, the game crashes.


« Reply #527 on: July 13, 2020, 02:49:19 AM »
hmmm... I'll start poking at it.

For reference the recipes including one above and below are:

.Cord.   [effort:1] [phys:hands,one-armed] *COMMON*   [patch:5]  /30/ %50% |-2|
{Cloth} #0.5# [remove] [patchwise]

.Leather rope. [effort:1] [phys:arms,one-armed]   *COMMON*  [assist:1]      /60/   %50% |-1| [patch:5]
{Leather} #1# [remove] [patchwise]
{Water} #1# [remove] [patchwise]      

.String.      "Cord"      [patch:5]   %15%   *HIDEWORKING*    /30/    [effort:1] [phys:hands]  [assist:1]
{Fibre from *}       #0.5#   [remove] [patchwise] 'Plant Fibres'


« Reply #528 on: July 13, 2020, 02:51:32 AM »
Sorry for being spammy, just an update on troubleshooting this issue. After realizing that I could manually type the key for each item on the Tying Equipment list, I used it normally, but then accidentally typed the key for the problematic Leather Rope. Didn't crash like always. I thought that the problem might be with the Encyclopedia being bugged and crashing every time it would display, which would explain why the rope didn't crash when I went directly to craft it, but would crash anytime the encyclopedia entry would display.

So I made a backup of my game folder, reinstalled the game for a fresh GAME.NFO, and restored my old modded game files but instead of the modded .NFO I used the brand new one. The issue was gone.

The weird part is that when I went to confirm this was the issue, and used the modded .NFO, the error didn't happen. So at least my game isn't crashing anymore, though you might want to check the Encyclopedia mod to make sure there's no issue with it and with the entry for Leather Ropes.


« Reply #529 on: July 13, 2020, 02:55:18 AM »
Reporting on bug tests, reproduction and so on is a >good< thing.

Currently, I fired up Cornan and was able to get into the menus for making the leather rope and string under neath. Thus I did not reproduce the problem on my own system.

Of note the game did just update 3.63 and that meant changing over the diy_glossary


As my local game failed to reproduce the reported error I suspect you are on BAC version minus one and had the diy_glossary over written and now the menus are confused that way.


Another suspect error is the stack overflow but those are rare; require tons of goods and/or farms within 1-2 tiles; unlikely to be occuring int two users at once. I doubt it as I know Sami has hunted that wee beastie few times.


1) make a zip backup of your current character directory (just in case)

2) download the most recent BAC and reinstall

The most recent is always on post 1 on page 1 of this thread. ITs also a few back too but I suggest just going to post 1. Im very regimental on updating it.

« Last Edit: July 13, 2020, 03:00:32 AM by Brygun »


« Reply #530 on: July 13, 2020, 03:06:30 AM »
Novrus loaded and made a leather rope the issue reported recipe.

Im really thinking its the recent vanilla game update issue, please redownload and reinstall the newest BAC on page 1.

Also, if I can't reproduce the problem locally there's not so much I can do to fix it.


« Reply #531 on: July 13, 2020, 08:08:08 AM »
Of note that the issue happened for me when I was on the correct match of BAC and UrW versions (which was a version ago, I haven't been fiddling with leather cords since, because I dread those crashes). I didn't have an issue crafting them (but that's possibly because I use the letter shortcuts to do that), but I had issues selecting (or simply hovering over them) them in my inventory.

I'll see if I can try and find a way to reproduce the crash consistently, though Zhid's troubleshooting of it having something to do with the onscreen encyclopedia entry for it might actually match the pattern of crashes I've also been facing (since the entry would pop up if I hovered over it in my inventory, but wouldn't pop up if I used the letter shortcuts to craft it).

Edit: I should mention I also was using the NFO from Extended Encyclopedia.
« Last Edit: July 13, 2020, 08:49:59 AM by BlankPaper »


« Reply #532 on: July 13, 2020, 02:26:40 PM »
Edit: I should mention I also was using the NFO from Extended Encyclopedia.

Request reporters run a test without the Extended Encylopedia.

This is currently about isolating the root cause. I don't use the ExEnc so we can add that as another pointer toward ExEnc.


If it is ExEnc then it may be related to it being a vanilla recipe


« Reply #533 on: July 14, 2020, 08:13:18 AM »
Brygun. The only time I'm crashing is when I'm looking a pile of items. It could be that it's related to a tying equipment problem. Issue is, I can't narrow it down because it seems to be random.


« Reply #534 on: July 14, 2020, 05:18:07 PM »
Brygun. The only time I'm crashing is when I'm looking a pile of items. It could be that it's related to a tying equipment problem. Issue is, I can't narrow it down because it seems to be random.

That actually happened before with too many items in an area. Yes, that was a thing. I helped debug that by having saved games. If it is then its a base game issue not a mod issue.

You mentioned a pile of goods so are you at your stead? how far away are your farm fields? These have been known to matter before.

Try posting in the general UrW bug thread. Make a zip of the game in case Saami wants to see it.


« Reply #535 on: July 14, 2020, 05:23:58 PM »
Does a vanilla version of the game crash with the save(s) in question?
To help is it's own reward.
Mods:;area=showposts;sa=attach;u=10 Player Quests, Arrow quiver, Bee hives honey & mead, Massive menus, Fish Farmer, Combat trainer, Player made markers, Weaving, Wood stacks, Chicken coop Fish cuts, string&bone.


« Reply #536 on: July 15, 2020, 12:46:44 AM »
Priv- Didnt test.

I thought it may have something to do with the homestead or the quantity of items but I just made some cords out of killed njerps' clothes and I got a crash while scrolling through the list.

Now, there where a lot of items in this area (scattered across hundreds of meters) but I didnt get a crash until I made the cords.

Bry- you brought up that a lot of items crash the game but I've had a lot more than this without instability in previous versions. I think everything is related to the cords lengths improvements in the base game, yet we would be hearing more about it so I'd say that it's a compatibility issue with the latest version of both the mod and base. I'll come up with something better but it's random (reloading fixes) so it's hard to pin down.
« Last Edit: July 15, 2020, 12:48:45 AM by teapot156 »


« Reply #537 on: July 16, 2020, 03:03:23 PM »
For teapot156

Looking over the notes here I'm not sure if you are running the Extended Encylopedia or not.
= Can you tell us if you are using EE?
== If you are using EE can you do test with it deactivated to see if you get the same problem?

Remember to save a copy of your character's directory somewhere else just to be safe.


« Reply #538 on: July 19, 2020, 07:02:58 PM »
I can confirm that I had the same crash when selecting rope. And I did have EE running at the time.


« Reply #539 on: July 24, 2020, 03:38:57 AM »
I can confirm that I had the same crash when selecting rope. And I did have EE running at the time.

Can people try having EE removed with BAC still there to see if it still crashes. I don't see this error on my BAC-yes EE-no game.