Topic: Performance issues when issuing commands  (Read 1210 times)


Rhaikh

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 15
    • View Profile
« on: October 31, 2017, 07:21:16 AM »
Windows 10, 3.40

I picked up the game again after some time of inactivity, and I noticed that I'm experiencing a lot of lag, maybe 200ms - 500ms between issuing a command (for example, rotate the character or move) and when it actually gets executed.  I also see the lag when doing things like moving the cursor in my inventory.  During long running commands like crafting, the game seems fine.

I tried moving away from my home tile, and I experience the lag there, too.  I also tried reinstalling and playing a new character.

In Resource Monitor, I don't see much CPU activity but occasionally I do see a lot of disk activity for URW files.

Any ideas I can try to remedy this?


Turns out my entire computer was on the brink of exploding.  Eventually I had to reinstall windows.  URW is fine!
« Last Edit: November 08, 2017, 04:00:38 AM by Rhaikh »

Rhaikh

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 15
    • View Profile
« Reply #1 on: November 01, 2017, 07:01:47 PM »
This might be due to Chrome, or some plugin thereof, slowing down my system.  I noticed it sped up quite a bit once I had closed my usual collection of 10 tabs, however the impact on URW is outsized.  The rest of my system behaves normally.

PALU

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 808
    • View Profile
« Reply #2 on: November 02, 2017, 06:44:06 PM »
UrW performs incremental saves in a number of situations, so disk activity is to be expected. I have no idea about the lag issue, though.

Rhaikh

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 15
    • View Profile
« Reply #3 on: November 02, 2017, 11:48:21 PM »
Ok, I don't think this is related to URW anymore.  I tried recording these lag spikes using OBS and OBS actually freezes at the same time, so the recorded video just looks jumpy instead of lagged (using mouse over hover in the main menu)