Topic: [Fixed - persists in 3.40] MacOSX, Setup Options do not save  (Read 2706 times)


bethefawn

  • Member
  • *
  • Posts: 11
    • View Profile
« on: August 24, 2017, 08:05:47 PM »
I'm attempting to increase night brightness and disable background musics, but after I alter the settings they do not persist. I also do not seem to have urw_ini.txt in my urw3-Darwin folder. Using 3.4.0 on macOS Sierra.

Anyone have any advice or are also experiencing this? Not game-breaking, but it would be nice to use these features.
« Last Edit: December 03, 2017, 03:18:54 PM by Sami »

bethefawn

  • Member
  • *
  • Posts: 11
    • View Profile
« Reply #1 on: August 25, 2017, 10:22:58 PM »
Maybe I should ask if anyone with my setup *is not* having this problem?

JEB Davis

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 282
    • View Profile
« Reply #2 on: August 26, 2017, 02:48:00 AM »
It could be that no Mac users have seen the post yet.
I would try to help, but I'm not a Mac user anymore.

Did you try a fresh install?

bethefawn

  • Member
  • *
  • Posts: 11
    • View Profile
« Reply #3 on: August 26, 2017, 03:16:31 AM »
Unfortunately, yes I have!

I'm noticing now, additionally, that there are actually quite few of the setup options it even lets me toggle, let alone save when exiting the options screen. The audio settings all reset to defaults after any changes. The only option that persists, oddly, is Map Lighting Effects.

koteko

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 221
    • View Profile
« Reply #4 on: August 26, 2017, 09:09:15 AM »
I don't have Mac either, but this is very strange. I was going to suggest making sure the permissions inside your folder are correct (since you don't have urw_ini.txt, and you can't persist option changes, it's probable that the game cannot save that file) but then why does MAP_LIGHTING_EFFECTS get persisted? Are you sure you can DISABLE it and persist it? The default is ON.

Do you know how to use a terminal on Mac? If yes, can you put the output of the command ls -l (run inside that directory) in a text file and attach it?

koteko

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 221
    • View Profile
« Reply #5 on: August 26, 2017, 09:10:09 AM »
Also, you aren't using Steam, are you?

PS: you can copy my urw_ini.txt into your installation directory, and see if, afterwards, you can modify options. Maybe the game can't create it but can modify it..
« Last Edit: August 26, 2017, 09:12:25 AM by koteko »

bethefawn

  • Member
  • *
  • Posts: 11
    • View Profile
« Reply #6 on: August 26, 2017, 09:11:34 PM »
Koteko, your setup options file saved the day!

To answer your questions, however:

I was absolutely able to toggle Map Lighting Effects and have it persist. It was one of few options that even allowed a change, and the only to persist. Quite odd.

I can use terminal, but I already had my urw3-Darwin folder open, and I always force my mac to show all hidden files, are you still interested in seeing the directory?

Also, not using Steam.

koteko

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 221
    • View Profile
« Reply #7 on: August 27, 2017, 09:00:09 AM »
Koteko, your setup options file saved the day!

To answer your questions, however:

I was absolutely able to toggle Map Lighting Effects and have it persist. It was one of few options that even allowed a change, and the only to persist. Quite odd.

I can use terminal, but I already had my urw3-Darwin folder open, and I always force my mac to show all hidden files, are you still interested in seeing the directory?

Also, not using Steam.

Happy to hear it's working!

I think it can be useful, yes. It's not about hidden files but about the file permissions. If by default the website package of Mac-URW comes with wrong permissions, it's going to affect other users. @Sami might want to fix that, in that case.

In particular, the commands are two (you must run those one by one after moving, with cd, into the directory containing urw3-Darwin):

Code: [Select]
ls -Old urw3-Darwin
ls -Ol urw3-Darwin

which should show us user permissions on all files as well as if MacOS is applying a "restricted policy" on the folder itself.

Also, where did you put the urw3-Darwin directory? Inside "Users/" or "System/"?

bethefawn

  • Member
  • *
  • Posts: 11
    • View Profile
« Reply #8 on: August 27, 2017, 06:38:49 PM »
Took me a few minutes to remember that a "\" is needed when a folder has a space character in the middle, argh, but here it is!

koteko

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 221
    • View Profile
« Reply #9 on: August 27, 2017, 11:03:48 PM »
Thanks!

I think the directory permissions might be at fault (depending on what user/group is the Urw binary executed as.. not sure about how Mac handles that). In short, permissions "r-x" in second position, for a directory, only allow reading and modifying files, not creating them.

So if the URW program is executed with a user NOT belonging to the group "staff", it would only be able to modify existing files but not create new ones.

I don't know if the above is the actual reason - it would be nice to test it. If you want to give it a try, just move the files urw_ini.txt and urw_ini_tmp.txt outside the directory, then type:

Code: [Select]
sudo chmod 775 urw3-Darwin
on that directory. This should change the permission line, when using "ls -ld", to:

Code: [Select]
TARDIS-AIR:urw3-Darwin bethefawn$ ls -ld
drwxrwxr-x  105 bethefawn  staff  - ...

Now just open URW again (it should be closed when doing the above) and see if the settings get persisted :)

bethefawn

  • Member
  • *
  • Posts: 11
    • View Profile
« Reply #10 on: August 27, 2017, 11:49:59 PM »
Thanks!

I think the directory permissions might be at fault (depending on what user/group is the Urw binary executed as.. not sure about how Mac handles that). In short, permissions "r-x" in second position, for a directory, only allow reading and modifying files, not creating them.

So if the URW program is executed with a user NOT belonging to the group "staff", it would only be able to modify existing files but not create new ones.

I don't know if the above is the actual reason - it would be nice to test it. If you want to give it a try, just move the files urw_ini.txt and urw_ini_tmp.txt outside the directory, then type:

Code: [Select]
sudo chmod 775 urw3-Darwin
on that directory. This should change the permission line, when using "ls -ld", to:

Code: [Select]
TARDIS-AIR:urw3-Darwin bethefawn$ ls -ld
drwxrwxr-x  105 bethefawn  staff  - ...

Now just open URW again (it should be closed when doing the above) and see if the settings get persisted :)

Done, and the result: none. However, ls -ld yields:

Code: [Select]
TARDIS-AIR:urw3-Darwin bethefawn$ ls -ld
drwxrwxr-x  102 bethefawn  staff  - ...

102 instead of 105. Don't know if that's a material difference.

koteko

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 221
    • View Profile
« Reply #11 on: August 28, 2017, 09:15:53 AM »
Thanks for testing :) that was my only bullet, my Mac knowledge is quite limited I'm afraid. To put it back:

Code: [Select]
sudo chmod 755 urw3-Darwin

bethefawn

  • Member
  • *
  • Posts: 11
    • View Profile
« Reply #12 on: August 28, 2017, 07:26:02 PM »
Well, we didn't solve the bug, but you definitely fixed my problem. Thanks a ton for your help!

Sami

  • UnReal World creator
  • Administrator
  • Member
  • *****
  • Posts: 361
  • UnReal World creator
    • View Profile
    • UnReal World
« Reply #13 on: September 07, 2017, 06:25:54 PM »
Went to check this out on my MacBook and it seems like urw_ini.txt doesn't come along with the standalone installer. So there's something hasty about Mac version packaging/installation. And when urw_ini.txt isn't properly in place setup options fail.
But bethefawn, if you copied koteko's urw_ini.txt to your installation folder then setup should work..but apparently it didn't.
Well, you might also try to find UrW under Applications (via Finder for example) and then right click the icon. Then choose open package / show contents or something, and find your way to Resources/ folder, and copy urw_ini.txt also there if it's not in place already. Then start the game again and see if setup has woken up. This is just a workaround until we've gotten a grip of the real issue.
- Sami | UnReal World creator

koteko

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 221
    • View Profile
« Reply #14 on: September 07, 2017, 06:40:39 PM »
My understanding is that it did work with my urw_ini.txt. The only strange thing at this point is the following:

Quote
I was absolutely able to toggle Map Lighting Effects and have it persist. It was one of few options that even allowed a change, and the only to persist. Quite odd.

So, when he didn't have the urw_ini, the only toggable/persistent option was Map Lighting Effect. I would be very curious to know why :D is it saved in a different file?