Topic: Bird thief quest; thief won't turn himself in?  (Read 3955 times)


« on: August 23, 2020, 02:24:58 PM »
I've completed the two main steps of the bird thief quest more than three weeks ago (finding the traps and feathers, doing the ritual). It seems to have worked (as in, I got an option to tell the quest giver that I did the ritual and then we proceeded to the next bit), and every day the quest giver tells me that the thief still hasn't turned himself in and that we might have better luck tomorrow.

I backed up my save with three days left on the quest clock, and I'm glad I did because the quest actually expired without the thief having ever turned himself in. What gives? Is it just luck of the draw? I completed the quest properly (or so it seemed to me) with tons of time to spare, can it just ... fail by itself?

Any help appreciated


« Reply #1 on: August 23, 2020, 02:31:35 PM »
Are you sure you did complete the feather step properly? There are various ways you can do it incorrectly (using a stove rather than real sauna [and I don't know if anyone has tested the new player buildable one yet], not using the correct number of feathers at the correct time, etc.). Usually there are enough feathers to perform the ritual a second time, just to make sure when time passes and the quest doesn't seem to resolve itself.

Thus, my guess is that you've happened to perform the ritual incorrectly, and so should make a new attempt.


« Reply #2 on: August 23, 2020, 02:44:13 PM »
I followed the ritual instructions to the letter; threw 3 feathers from the stolen bird on the coals of a burnt-out fire I made on base rock (a mountain, in that case). I'm stumped. I'll try again, I suppose.
« Last Edit: August 23, 2020, 02:45:55 PM by BlankPaper »


« Reply #3 on: August 23, 2020, 04:54:19 PM »
Well, I give up. I tried 3 or 4 more times without success. I had tossed the feathers onto a pile on my homestead that already had a couple from the same species, and maybe the game internally keeps track of which bird they each belonged to originally and I got unlucky? Either way, no thief turned himself in. I'm not sure what went wrong originally, but I couldn't seem to salvage it.

Appreciate the help nonetheless Palu!

Edit: Gave it one last try, actually went and searched the message logs to see if I had the right feathers (and I did), and what's more is that every feather of that bird that I own is actually from the quest grounds and weren't mixed with other feathers. So I do have the right feathers. I also tried using a village sauna this time around, instead of a fire on base rock. Either way, my efforts were in vain because no thief turned himself in either. Oh well!
« Last Edit: August 23, 2020, 05:27:04 PM by BlankPaper »


« Reply #4 on: August 26, 2020, 07:47:36 AM »
I've occasionally experienced this too. I think it's a bug but I haven't been able to pinpoint how or why it happens.


« Reply #5 on: November 09, 2020, 04:30:40 PM »
hey i cant seem to complete the ritual, i have tried in a sauna and on a mountain i wait for the fire to burn out then. i tried both pushing the feathers and throwing the feathers in the sauna and with the mountain i tried pushing throwing and droping the feathers. i read that the feathers sould get consumed but that is not happening. what am i doing wrong?

apparently it worked. but if someone could specify what method was correct i will be grateful.   
« Last Edit: November 09, 2020, 05:12:11 PM by migmigogdem »


« Reply #6 on: November 10, 2020, 10:48:39 PM »
Feathers thrown or pushed, on fire remains: sauna stove or base rock. Should do the trick.
But if the feathers are NOT the quest specific ones, it’ll naturally fail to work as scripted.