Topic: URW Controller  (Read 286 times)


Montiebhoy

« on: July 17, 2020, 02:36:13 AM »
Hi, newcomer here.

I downloaded the controller app but it won't connect. I have tried everything, firewall, ports etc.

Any ideas?

EDIT: I finally figured it out, it only works via wifi, I had my PC connected via ethernet. Might be worth sticking in the troubleshooting page.
« Last Edit: July 17, 2020, 02:53:12 AM by Montiebhoy »

Erkka

« Reply #1 on: July 17, 2020, 01:11:33 PM »
Hello!

Glad to hear that you found a solution which works for you! It is supposed to work also with PC connected via ethernet. During the pre-launch test phase automatic connection worked fine for all the tested devices. But now it seems that with some configurations the automatic connection fails.

If you are somewhat familiar with the technical side and willing to help with further troubleshooting, please send me a private msg or just reply to this thread.

Like, it would be helpful to know these things:

- on your computer, when connected via ethernet, what is the local ip of the computer ?
- after enabling the controller at UrW main menu, then choose ABOUT, and it should tell the computer ip address - does it report a correct address?
- install any UDP listener app on your android device and ask it to listen to messages at port 8012, then try pressing F10 on UrW - the UDP listener should pick up a "hello I'm here!" type of message sent by UrW. You can try if that message only comes thru when the computer is connected via WiFi. And if the UDP listener recognizes the message when the PC is connected via ethernet, then the bug clearly is in the controller app failing to parse the message.

Ps. lately I've been pretty busy with my main work. But next week there will be a fresh release of the controller app, mirroring the changes in UrW keyboard commands (eg. dropping the character log and introducing a separate button to command dogs and companions)

Montiebhoy

« Reply #2 on: July 18, 2020, 04:41:04 AM »
Cheers for getting back to me!

I checked the ip's in ipconfig and in UrW and they matched.

I also downloaded UDP Monitor and only recieved a hit when connected via Wifi.

Hope this helps! I'll keep an eye out for the new release.


Just as I was about to send this I had an idea. My suspicion was a rogue Hamachi install from days gone by, I was right. I was picking up the wrong ip.
All is working as it should on Ethernet!