Topic: building a shelter  (Read 4268 times)


« on: September 25, 2017, 03:21:36 AM »
I'm new to this game, but already addicted to it! Frustrated, however, by the process of building a shelter. I can't seem to get the walls to connect, and often I can't even get them placed where I intended. I placed a north wall with shutter, and it went up just fine, but when I tried to connect to the left edge of that wall section I got very strange results. I had to remove the wall with shutter in order to successfully build the wall section to the left of it.
Another issue is the SE corner never seems to form the backwards "L" shape that the you'd expect. I've built the NE and NW corners, and both form a sort of "L" but the SE is a simple vertical line. I can't build a wall section to the left of it, as the game says that area is not clear of objects. I can walk through the area, and can't pick up any objects in that location. So why can't I connect to this SE corner?
See attached image, where I nearly completed the SE corner. I've completed and torn it down twice already, and this 3rd time looks like it will turn out the same.
Can anyone explain the secret of placing wall sections? On the surface, it seems pretty obvious how to do it, but the obvious method isn't working.


« Reply #1 on: September 25, 2017, 04:02:11 AM »
I think you're actually doing it right, but maybe overthinking it. The SE corner from the picture you show looks right to me. You can see the overlapping logs that would form it. The L shape might be more pronounced looking on the northern corners because of the isometic view.

As far as shutters and walls not connecting, you need to complete things to see how it will look. Walls with shutters will snap into place when you've put in the ceilings/floors, and walls will connect up when they are all finished. It just sometimes doesn't look like it when you are building. It's as simple as:


With C being the four corners, N being north walls, E being east walls, W being west walls, S being south walls, D being a door and X being the ceiling/floor tiles. Also, your door can go anywhere on the south.

You can make cabins as big as you like (as far as I know there isn't a maximum) following this pattern, or as small as:


Though there isn't much point for a single square cabin. Also, if you want it to work as a smokehouse/sauna I believe there is a limit to how big it can. I always build them 4x4 (2x2 interior) or like my first design above.

Edit: Didn't catch the part about the it saying there is something already there. It doesn't look like there is based on your picture (though your character's head is in the way hah). If you built something straight up from your character in the picture it would be a southern wall (or a door). Maybe you are actually trying to build on the corner you've already built by accident somehow?
« Last Edit: September 25, 2017, 04:05:32 AM by spamgoose »


« Reply #2 on: September 25, 2017, 04:11:48 AM »
I've attached an image of a cabin I am in the middle of building. You can see in it that the shutter walls are all out of whack. That's normal... as soon as there is a floor they make sense. Also you can see the SW and SE corners in finished mode.


« Reply #3 on: September 25, 2017, 04:15:06 AM »
I appreciate your response! It helps a lot, but I'm still confused about how things get positioned. See the new screenshot attached here. I decided to finish the SW corner, and you can see where I'm standing. I had the logs at my feet, and selected the 8 key on the keypad, which I thought would mean the corner would be placed directly above me. But it went up and to the right. Do corners auto-snap to the closest wall section? If that S wall section was not already there, would the SW corner have appeared above me?


« Reply #4 on: September 25, 2017, 04:56:04 AM »
No, there is no auto-snapping. I think there might be something wrong with your keyboard. If I am in the same position as your character, clicking 8 would build something straight above me no matter what. The arrow keys work just as well (but no 45 degree angles obviously), so try using the up arrow. That *should* work.


« Reply #5 on: September 25, 2017, 05:38:22 AM »
I was wondering if it might be my keyboard as well, as this is not the only instance of keys not working as expected (not the only instance in this game, but I've had no problems with keys outside of this game). I  disassembled the SW corner, and again tried to put it directly above me, this time using the up arrow key. Same result.

My character is using way too much energy messing around with these walls.


« Reply #6 on: September 25, 2017, 05:52:12 AM »
Yea, could be a bug related to a particular keyboard configuration. Maybe wait and see if someone else has any idea, and if not, make a post in the bug area of the forum. In the meantime, try using shift-g to pick things up around you (it uses the same key configuration), and see if its all off by one or something. Maybe 7 is your up. Less energy intensive than building walls. Play around by picking up a rock and see, I guess.


« Reply #7 on: September 25, 2017, 09:34:36 AM »
I'd try standing in a different relative position to where you want things built and try the appropriate key for that, but I don't think I've seen any other cases of people having trouble with directions.
I think spamgoose's suggestion of trying out the 'G'et command for different directions is a good one: it doesn't take much character effort to perform such tests.
If there IS something wonky with your keyboard it could explain the message about something in the way when attempting to build at an empty location, if UrW actually tries to build in an occupied one.

Some terminology nit picking: A "shelter" in UrW is a simple lean-to type building with its own entry in the build menu, while your actually building a cabin/house (I don't think those buildings have a fixed name). Hence, the subject name is mildly misleading.


« Reply #8 on: September 25, 2017, 09:43:19 PM »
I had major troubles with walls being built in the incorrect spot when I first started building things, clicking 4 would build at 7 three in four times, and clicking 2 would build at 1 maybe half the time. It only occurred with building walls, all of my other direction selection was fine. It wasted a ton of time, cause you wouldn't know if it were right or not until it was built enough for a silhouette, an hour or so of work. Solved it by just building walls from the other directions, and now it doesn't happen anymore when I forget and use the formerly bad directions. I still always pause every wall after an hour to check they're placed right.
Iiiiii juuuuust want to set the woooooooorld onnnn fiiiiiiiiireeeeeee.... Iiiiiiii don't want to start a flame in your heeeeeeaaaaaaaaaaarrrrrrrrrrrt.
And with your admissiiiiion you feeeeel the same, I'llllll have reached the goaaaal I'm dreamiiiing offfff, believe meeeeee