Topic: [SOLVED & Fixed] incompatibility issues with other software: URW wants libcurl3  (Read 2187 times)


Twixter

  • Member
  • *
  • Posts: 2
    • View Profile
« on: August 14, 2018, 07:51:32 PM »
My OS is Linux Mint 19, which uses Ubuntu 18.04 repositories.

If I do a system-wide install of URW using the downloaded deb file and the Gdebi installer, my libcurl4 package gets removed and replaced with libcurl3. It also removes all other software which required libcurl4, such as Scilab for example.

The tarball download has the same problem.

I'm not sure if this is the correct forum to ask in, but would it be possible to create a virtual environment, or sandbox, in some local folder, where I can run URW without interfering with my other software?

Thanks in advance.
« Last Edit: October 17, 2018, 10:26:11 AM by Sami »

Twixter

  • Member
  • *
  • Posts: 2
    • View Profile
« Reply #1 on: August 16, 2018, 08:24:12 AM »
The answer I found was to install Virtual Box on my machine.


https://www.virtualbox.org/wiki/Linux_Downloads

This may be useful information for someone else.

Almyon

  • Member
  • *
  • Posts: 3
    • View Profile
« Reply #2 on: September 03, 2018, 12:34:48 AM »
I have this problem also, however virtualbox is unfortunately a poor option for me at this time. I'm unsure if I should be posting here or making a new topic, as this is precisely the same problem which I am having.

Is there a way to bypass this libcurl requirement on installation?

koteko

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 200
    • View Profile
« Reply #3 on: September 03, 2018, 08:58:23 PM »
I created a new deb package for you, by changing the "libcurl3" requires to "libcurl3 or libcurl4". As long as the game does not use libcurl in a way incompatible with libcurl4, it should work. Give it a try.

This is the change, for the curious (in the file urw/DEBIAN/control, if you unpack the deb):

Code: [Select]
Depends: libsdl2-2.0-0, libsdl2-image-2.0-0, libsdl2-mixer-2.0-0, bash, libcurl3|libcurl4

Let us know if it works, so Sami can fix the package.

https://www.dropbox.com/s/l28h30lx2pebt8g/urw_3.51a_amd64.deb?dl=0

Almyon

  • Member
  • *
  • Posts: 3
    • View Profile
« Reply #4 on: September 09, 2018, 01:57:08 PM »
Oh gosh that's fantastic! Thanks so much! This really makes my week :D I have booted it up successfully and I'll be playing it more soon. Can't wait to get back into the unreal world.

If I may ask, is it complicated to modify a deb in this way?

koteko

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 200
    • View Profile
« Reply #5 on: September 09, 2018, 06:15:10 PM »
It's very simple, give it a try :)

Code: [Select]
# unpack the deb within the urw/ directory
sudo dpkg-deb -R urw_3.51_amd64.deb urw

# now we edit the control file, any text editor will do (change the line as I wrote in previous post)
gedit urw/DEBIAN/control

# save and close that file when you are done

# let's create the new deb, ready to be installed
sudo dpkg-deb -b urw/ urw_3.51a_amd64.deb

koteko

  • Honorary Lifetime Supporter
  • Member
  • *
  • Posts: 200
    • View Profile
« Reply #6 on: September 09, 2018, 06:15:49 PM »
@Sami can you please update the package to make either libcurl3 or libcurl4 acceptable requirements, as outlined above?

Almyon

  • Member
  • *
  • Posts: 3
    • View Profile
« Reply #7 on: September 09, 2018, 07:15:16 PM »
Wow, that IS simple. Thanks again, both for the help and the knowledge!

Sami

  • UnReal World creator
  • Administrator
  • Member
  • *****
  • Posts: 281
  • UnReal World creator
    • View Profile
    • UnReal World
« Reply #8 on: October 17, 2018, 10:25:44 AM »
This will get fixed in the next update. libcurl dependency was redundant leftover, requirement will be removed completely.

Fixed - persists in 3.51
- Sami | UnReal World creator