Topic: Segmentation fault  (Read 1402 times)


bbbart

  • Member
  • *
  • Posts: 1
    • View Profile
« on: October 07, 2017, 11:12:50 AM »
Hi,

I have played quite a lot in the past, but it has been a couple of months since I last found some time for it. This morning, I fired up the game, but didn't get far: Segmenation Fault (I'm playing on Arch Linux). Hm, strange, it was still the same installation as before.

I went to download the latest version from the website, but alas, both the Arch packaged version (64bit) and the tar.gz gave me binaries that segfaulted at the same point. From the GUI, it looks like the segfault happens at "Loading audio: wind", and a strace tells me the last thing happening is openat(AT_FDCWD, "GAME.NFO", O_RDONLY)  = -1 ENOENT (No such file or directory) (GAME.NFO doest exist however, at /usr/share/urw3/GAME.NFO symlinked to ~/.config/urw3-Linux/GAME.NFO).

Sooo.... I'm really yearning to continue the adventure, but am stuck, I'm afraid.

I'm a bit lost for what to do next, but I'd be happy to try your suggestions.

Thanks!
« Last Edit: October 17, 2018, 10:32:56 AM by Sami »

Silenia

  • Member
  • *
  • Posts: 47
    • View Profile
« Reply #1 on: October 07, 2017, 11:19:48 AM »
Appears to be the same issue as described here. https://www.unrealworld.fi/forums/index.php?topic=857.0

If it's the same issue, you might be able to play with audio off for the moment as a work-around. As you probably can't actually load up the game far enough to change settings, you'd have to change it in the urw_ini.txt

bbbart

  • Member
  • *
  • Posts: 1
    • View Profile
« Reply #2 on: October 07, 2017, 06:13:42 PM »
Yes, you're right. I was afraid it would be one of the libraries urw is using, indeed.

Setting AUDIO to NO in urw_ini.txt does the trick for now.

Thanks a lot!

werepacman

  • Member
  • *
  • Posts: 29
    • View Profile
« Reply #3 on: September 09, 2018, 11:17:25 AM »
I have the same issue.

Strange but if I try to start game many times it will actually work.

1 of 10 times.