Topic: [not a bug, my bad] Can't craft staves  (Read 5357 times)


« on: June 12, 2018, 07:06:06 PM »
New player here. As the title says, I can't craft staves. I'm following the new player guide on the wiki, and I've gone through the crafting and keyboard commands articles, so it's not that. I've tried both with knife in hand and in inventory. I've done absolutely zero modification to the game files, I've tried a fresh install, new character and it's the most recent version of the game. I cannot track down what this issue is, so hopefully you guys can help me out. Screenshot with the Lumber menu open. Screenshot of my character's skills (as generated through quick start), in case it matters.
« Last Edit: June 13, 2018, 09:52:58 PM by Sami »


« Reply #1 on: June 12, 2018, 07:22:19 PM »
It looks like diy_glossary.txt is missing or the game somehow cannot access that file...

Check diy_glossary.txt and your AV.

How about other items? Building, Clothes and Weapons. Both Building and Clothes don't use diy_glossary.txt  and should always be there. Weapons to check if it is just Lumbers or the problem of the entire file.


« Reply #2 on: June 12, 2018, 07:55:09 PM »
I did notice that Weapons lacked any entries as well, but I didn't know if it should always have visible entries. Building and Clothes do show entries.

I don't know what AV is, being extremely new to all this, but here's my diy_glossary.txt contents.

Edit: Okay, well, I restarted my PC and now it works just fine. Really strange, but I'm not going to complain.
« Last Edit: June 12, 2018, 09:22:12 PM by mightylcanis »


« Reply #3 on: June 12, 2018, 11:36:29 PM »
FYI: AV = Anti Virus. Those programs have a tendency to "quarantine" files for more or less random reasons. Since you got it working (congratulations!), that wasn't the cause, though.