Topic: Graphical issue, truetile stuff  (Read 1704 times)


Greendale

« on: January 05, 2018, 02:19:49 PM »
Heya!

I have Buoidda's Crafts installed. For some reason most (not all1) of the items it adds have the background color of the respective truetile files showing. It is extremely frustrating to have these neon squares all over the place and I would be pleased to live without them. ;D

1: Birch roots and Alder Fibre seem to work properly

Could someone help me out with this?
I have tried re-installing everything already.

Playing on a macbook air
MacOS Sierra 10.12.6
« Last Edit: January 05, 2018, 02:22:05 PM by Greendale »

PALU

« Reply #1 on: January 05, 2018, 04:45:59 PM »
This won't help you, but I haven't had any issues with it either in 3.40 or 3.50beta (I've modified the mod a bit, but have done nothing to its tiles). Thus, it seems to be an issue of a clash between those and your environment (I'm on Windoze).
At a guess, it's an issue of some image layer or other being displayed differently on different platforms, but I'm not graphics savvy.

caethan

« Reply #2 on: January 05, 2018, 05:06:11 PM »
I've had this problem before.  Macs don't handle the presence of an alpha channel in the tile PNG files well - it'll refuse to remove the background color.  You can fix them with the default Preview app:

  • Open the offending file(s) in Preview
  • Command-Shift-S to Duplicate (make a copy)
  • Command-S to Save
  • Deselect the Alpha checkbox
  • Save over the original file

You can also bug the original authors to get rid of the alpha channels in the files, but for mods that aren't being updated anymore that might not work.

Greendale

« Reply #3 on: January 05, 2018, 06:36:18 PM »
Thanks!

I'll try to remove all the alpha channels. Problem is, there are over 50 files. Ugh...  :P

It's sorta weird that the game handles vanilla files just fine but when it comes to modded ones, it goes all neon on me :D


Privateer

« Reply #4 on: January 05, 2018, 06:40:07 PM »
When images are generically edited or created in windows, the alpha layer problem appears. From what I've seen.
« Last Edit: January 05, 2018, 06:47:08 PM by Privateer »

caethan

« Reply #5 on: January 05, 2018, 10:55:24 PM »
If you're deft with a command line, you could script up something to automate the process with ImageMagick: https://www.imagemagick.org/script/command-line-tools.php


vetrarnott

« Reply #6 on: November 07, 2018, 08:55:27 PM »
If you have photoshop, you can also remove the background color altogether.

-Open the png in Pshop
-At the toolbar, go to Select > Color Range
-Use the eyedropper tool on the background color. Then set Fuzziness very low, like 10%. Confirm

Now you have the background color selected (watch out for selecting similar colors in the icon). You can remove it in two ways.
-One way: add a layer mask by clicking "add layer mask" at the bottom of the layers panel. Select the mask, and invert it by pressing Cmd-i. The background should now be blank. Save as a png with transparency.
-Other way: duplicate the locked original layer. Select the layer copy, and press delete to remove everything in the selection. Press Cmd-d to clear the selection. After that, select the locked original layer and delete it. Save as png with transparency.